Support for VS2010 with Latest C++ REST SDK

Feb 15, 2015 at 8:31 AM
Hello Casablanca Team,

My project requirement needs C++ REST SDK support on VS2010.

Manage NuGet Packages for solution always prompt the latest of C++ REST SDK. If I install the latest SDK, then I am not able to compile my basic http request code. It throws many error related to Chrono, ratio and other external dependency file.

Since my projects is completely on native C++ code base, so we need support for VS 2010 with latest REST SDK API's as soon as possible.

Thanks
Vijay
Coordinator
Feb 16, 2015 at 3:57 PM
Hi Vijay,

Our latest release don't support Visual Studio 2010 anymore. Mainly due to compiler and standard library features that are present in newer versions. If you can't use a newer version then you could stick with one of our older releases. The last one that we produced binaries for Visual Studio 2010 was 1.2.0. If you want to build from source the last version that contained the 2010 project files was 1.3.1. If you aren't using our latest release you will need to use the NuGet package manager console to specify the version to download, i.e. "Install-Package cpprestsdk -Version 1.2.0".

Thanks,
Steve