getting an assertion when creating a request

Jan 25, 2015 at 10:57 AM
Edited Jan 25, 2015 at 10:57 AM
Grabed this simple code sample right from the microsoft website:
// Manually build up an HTTP request with header and request URI.
http_request request(methods::GET);
request.headers().add(L"MyHeaderField", L"MyHeaderValue");

when I run it in my debugger stepping through my class I get an assertion in the line
http_request request(methods::GET);

when I step into it it seems to have a problem with shared memory?

The assertion I am recieving is as follows:

Debug Assertion Failed!
Program: it lists my exectuable file path here

File f:\dd\vctools\crt\crtw32\misc\dbgheap.c
Line 1424
Expression: p_FirstBlock ==p_Head

I am assuming this is some kind of configuration issue?

Any suggestions on how to track this problem down? or what it could be?
Jan 26, 2015 at 5:50 PM
I just wanted to add that on a second pass of searching the disscussion threads I did manage to find this similar thread.

I have since changed my isolated project to use \MDd to see if that would fix the problem and it worked great.

The problem remains that this does not seem like a long term solution for me as I need to integrate this project into a large visual studio solution compiled with \MTd which is also dependant on many other external libraries all compiled for \MTd. The overhaul to change the preexisting projects in the solution to use \MDd would be treacherous.

Visual studio does not appear to like mixed settings in different projects and likely most of the application code will have dependencies on the client server project. Does any one have any idea how I can resolve this problem and get back to using \MTd?

Thanks very much!
Jan 26, 2015 at 6:32 PM
Hi robyn_fry,

We don't officially support static linking right now. Some others have been successful on their own building, you can see the details in our feature request.