Listener silently fails to open on Ubuntu Linux 14.04

May 5, 2015 at 5:48 PM
I'm trying to create a restful listener. I compiled everything from source with cmake and gcc 4.8.2.
I've tried launching the blackjack server demo, it launches correctly but if I nmap localhost, I don't see a new open port.

I've also tried starting my own listener as follows:
// **************************************************************************************
int main()
web::http::experimental::listener::http_listener listener(web::uri(""));"GET"), handle_get);"PUT"), handle_put);"POST"), handle_post);"DEL"), handle_delete);
{[](){std::cout << "Listener Started" << std::endl;}).wait();
}catch(std::exception &e)
    std::cout << e.what() << std::endl;

return 0;

// *******************************************************************
This successfully enters the while loop, and "Listener Started" is print to console, but there are no open ports.

I've tried running this as a normal user and as root.
I've tried entering my IP address, "localhost", and "" as the URI.