How to build CPPRest 1.0 on MAC

Dec 4, 2014 at 9:38 AM
Hi all,
  • I done using CPPRest 1.0 on Windows. Now I want to use on MAC.
  • I clone code from server and build successfully by Xcode 5.0.2 on Mac 10.8.5 but the lastest version was built by -std=c++11 and my project are building by -std=GNU++ therfore I can't use CPPRest latest version.
  • Now I reset code to version 1.0 the same with on Windows. But not find the CMakeList to build on Mac.
-> So anyone can help me to build version 1.0 or build latest version by -std=GNU++ instead of -std=c++11

Thanks so much
Coordinator
Dec 4, 2014 at 10:08 AM
Hi coiphim,

C++ Rest SDK version 1.0 does not support OSX. Also, all versions of the C++ Rest SDK require -std=c++11.

What is preventing you from upgrading to the most recent version (2.3) and compiling your project using -std=c++11?

roschuma
Dec 5, 2014 at 12:52 AM
thank Roschuma

so I need to try with other sdk because my project is big project from adobe therefore change to -std=c++11 not good way.

thanks,