Windows Firewall settings

Nov 12, 2014 at 4:25 PM
Hi,

Is there any standard set of documentation to let Casablanca services out through Windows firewall? I've used netsh to add a http reservation, and opened up access to the service exe in the firewall config, but we still can't connect from the outside. Connecting inside on the machine it's fine, so it must be the firewall.

Damien
Coordinator
Nov 12, 2014 at 10:46 PM
Edited Nov 12, 2014 at 10:47 PM
Casablanca should act just like any other program, so any guidelines should apply. Depending on what ports you are using, you may need Administrator access. Have you tried temporarily disabling the firewall for testing?

roschuma
Coordinator
Nov 12, 2014 at 10:50 PM
Hi Damien,

If you are using our http_listener, what address are specifying to listen on? It sounds like you are having the same issue as this discussion, take a look at it. For Windows to receive requests from outside of your machine you have to listen as an administrator and shouldn't be specifying 'localhost'.

Steve
Nov 13, 2014 at 3:56 AM
Right, I fixed the ip address to listen on http://*. This works if I POST to the service on my local machine listening on *. If I POST to the same service running in a VM on another machine, it times out, and nothing happens on the service. If I disable Windows Firewall on that VM, and POST to it, I get a 503 Service Unavailable. It all works on the Linux build, so I have a config problem somewhere...

Damien