v2.3: Dependency on Boost 1.56

Nov 4, 2014 at 2:43 PM
FWIW, I notice that http_client_impl.h uses:

include <boost/system/error_code.hpp>

which does not exist in Boost 1.55. Updating to nuget package Boost 1.56 resolves the issue.
Coordinator
Nov 4, 2014 at 4:46 PM
Hi BSalita,

Hmm that seems strange, I'm actually still using Boost 1.55 for my development and it contains error_code.hpp. I'm using the Boost NuGet package 1.55.0.16 and the file is located under packages\boost.1.55.0.16\lib\native\include\boost\system. Perhaps there is something wrong with your setup?

We probably will update to 1.56 for the 2.3.0 release regardless.

Thanks,
Steve
Marked as answer by BSalita on 11/4/2014 at 4:23 PM
Nov 4, 2014 at 11:25 PM
Ugh, disregard. I see the file in the same path as you state. I don't know why Visual Studio 2013 reported the #include as missing. It compiles fine now.
Coordinator
Nov 4, 2014 at 11:26 PM
Glad to hear!