Timeout (after 2 minutes) on http_listener

Oct 17, 2014 at 2:36 AM
It appears that the HTTP listener times out after 2 minutes (or maybe more). I am performing a task that can potentially take 30 minutes. Is there a way to increase the timeout?
Oct 17, 2014 at 6:09 PM
Take a look at the reference documentation for http_listener_config.


You can specify a timeout using .set_timeout() and pass this config into the listener's constructor.

Oct 18, 2014 at 5:34 PM
Hi Nagendra17,

Whether you can set timeouts explicitly also will depend on what platform you are running targeting. Setting of timeouts is only implemented on Windows right now. There is an open feature request for implementing on other platforms here.