developing with embarcadero RAD Studio

Jun 3, 2014 at 7:49 AM
I'm looking for a powerful C+++ REST SDK but I develop with Embarcadero RAD Studio. Can I use Casablanca anyway?

Thx for your help!
Jun 3, 2014 at 8:43 AM

Certainly! Casablanca is a cross-platform library that builds (on windows) with the visual studio 2013 and 2012 compiler toolsets. While we don't officially support RAD Studio, if you can compile with the VS2013 or VS2012 tools, you can use Casablanca.

Jun 3, 2014 at 8:50 AM

But where do I get the needed C++ Rest SDK NuGet Packages from? In the tutorial the NuGet Package Manager is needed but I don't have this one....
Jun 3, 2014 at 8:58 AM
The NuGet packages are only applicable when using Visual Studio. Since you're not using Visual Studio, you'll need to build Casablanca from source.

Here is a link to the documentation to build on windows. After building via msbuild or visual studio, you should have dll files you can link to in RAD Studio.

Marked as answer by snakys on 6/3/2014 at 1:00 AM
Jun 3, 2014 at 8:59 AM
thank you very much!
Jun 4, 2014 at 8:24 AM
I tried this. But I command line doesn't know "msbuild dirs.proj /p:Configuration=Debug /p:Platform=x64". I'm in the right Directory.
What can I do?
My next question ist: What do I have to put at Configuartion? Is Debug right?

Jun 4, 2014 at 8:28 AM

You've likely skipped over the step
If you're using PowerShell, you can now set up VC++ compiler toolset by running the setup_ps_env_for_VS2013.ps1 script.
Alternatively, you can open a Visual Studio Command Prompt from inside visual studio.

Next, you should choose either Debug or Release for Configuration. The Debug configuration will add more checks and avoid certain optimizations that make it more difficult to track any issues that occur when using the library. For development purposes, you probably want the Debug version. When you'd like to release or perform performance tests, you should use the Release configuration.

Jun 4, 2014 at 9:16 AM
no I didn't. I install VS 2012 Express and startet Setup_ps_env_for_VS2012.ps1. PowerShell is starting then but there's no report if the Installation worked or not.

Jun 4, 2014 at 9:26 AM
Try instead opening a Visual Studio Command Prompt from the menu Tools -> Visual Studio Command Prompt within visual studio 2012.

Jun 4, 2014 at 10:48 AM

now it worked. How does it go on now? I ran the tests, everything is fine, how do I go on now to work in RAD Studio with casablanca?
Jun 4, 2014 at 10:51 AM
Good to hear.

You'll need to add appropriate linker and compiler options to include the Casablanca headers and link against the produced dll. We don't have a step-by-step for RAD Studio, since it's not a supported IDE.